
Chapter 15   Custom Form/Report Tool
This Chapter covers the Custom Form/Report Tool in Big Business and additions to Big
Business Documentation including:

•  Designing, Editing, and Printing Custom Forms

•  Exporting, Importing, and Deleting Custom Forms

•  Templates, Line Item Templates, and 1099s

•  Accessing Related Information

•  Formatting Numbers and Adding Variables

• Troubleshooting

Chapter 15   Custom Forms and ReportsCover Page

Chapter 15   Custom Forms and Reports Cover Page15 - 1



Custom Forms: Using
The Custom Form/Report tool lets you edit the layout of forms and create simple
reports.

•  The Custom Form/Report tool is a separate application running in a window.

•  Click New and choose a Template based on where you want it to print (e.g. Invoice).

•  Work must be saved using the File menu within the window.  Closing the window
without saving will not alert you to save changes and all new changes will be lost.

•  Use Save As... to avoid writing over a working layout with an untested layout.

•  Page Setup from the File menu formatss the form for your current printer

•  Test your form from its place of use within Big Business, e.g. print an Invoice.

•  Templates resemble the Built-In forms in appearance but are entirely distinct.

•  "Line Item" Templates suppor Comments and including Fields from the Item Card.

•  Reports print from a QuickSearch, relying on its searching and sorting.

•  Templates are pre-programmed; the included version of the Custom Form Report tool
does not support programming.
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Custom Reports: Designing
Big Business allows you to create customized forms and reports. For
example, if you have preprinted stationery that doesn’t work with the standard
arrangement of a Big Business invoice, you can rearrange the fields to make them fit.

A number of templates are supplied with Big Business. You use these templates as the
basis for customized reports and forms. You make changes to the template in a special
window that allows you to move fields, edit text, and make other revisions.

After you have created and saved a custom report and form, it becomes available as a
print option in appropriate situations. See “Printing Custom Reports and Forms” later
in this chapter for more information.

To create a new custom report:
1. Click the Custom Form/Report tool in the Info Center toolbar.
2. Click the New button in the Custom Forms/Reports window.
3. In the Select a Template list, choose the template you want to use as the basis for a
custom form or report, then click the button.
4. When the template appears, make any necessary revisions.
5. Choose Save As from the File menu inside the Custom Forms/Reports window.
6. Give the report or form an appropriate name, then click the OK button.
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Custom Forms: Templates
Big Business provides a variety of Templates for use with the Custom Form/Report tool.
These Templates have the following attributes:

• Templates resemble the built-in printing layouts for easy understanding of their
contents.  The Custom Form/Report tool does not provide direct access to the built-in
forms, nor does it have all the capabilities of the built-in forms.  If you are unable to
accomplish your goal with the Custom Form/Report tool, send email to:
support@bigbusiness.com.

• Templates determine the appropriate location for printing your custom form.  For
example, if you wanted a cover letter for each Sales Order, you would modify the
Sales Order Template to be a letter by selecting and deleting the items on the
Template and inserting text.

• Some of the graphics on a Template affect its page size.  For example, the box around
line items on a Invoice Template limits the area.  Removing this box may allow the
form to stretch across multiple pages if enough Line Items are entered.  To make the
box "not print" select it, and change its coloration to white.

• Templates may provide limited access to related fields.  For example, the Invoice
Template allows you to select fields from the Invoice and from the Invoice Line
Items, but not from the Item Card.  On the other hand, the Invoice Line Item
template can access the Item Card.
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Custom Forms: Line Item Templates
Big Business includes the following Line Item Templates:
•  Quote, Line Items
•  Sales Order, Line Items
•  Invoice, Line Items

Line Item Templates offer several advantages:
•  better multi-page control
•  option to include fields from the Item Card
•  variable-depth Comments
•  option to include space or a horizontal rule between line items

Line Item Templates require exact positioning of the Section lines (Body, Total, Footer).

The Body section (everything below the Header line and above the Body line) repeats
for each item, so, for example, to add more space between items, move the Body line
down, which first requires moving everything below it, down.

The Footer line marks the bottom of the page, so, for example, to print the totals closer
to the bottom of the page, move the Footer line up.  Anything below the Footer line will
not print, and there is usually a limit on how close to the edge your printer can
actually print.
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Custom Forms: Printing
After you save a custom form or report, Big Business automatically makes it available as
a print option in appropriate places. For example, if you create a new form using the
Invoice Line Items Template, it will be available to print from the Invoice and Invoice
QuickSearch tools.

To print a custom report or form:
• During the printing process, select the custom report or form in the Print Options

dialog box.
• When creating a Custom Form always set the Page Setup!

Your Custom Form may also be selected in the appropriate Printing Defaults.  For
example, you may select a customized Invoice, which you have created and saved, to
be be your default selection in an Invoice Print Option list.

To select a customized Invoice as a default layout when printing Invoices:
1. Open the Customer Prefs.
2. Select Invoice Printing Defaults.
3. Scroll to the bottom to find your customized Invoice layout.
4. Click once to select one copy; double-click to specify a number of copies.
5. Click the OK button to save Invoice Printing Defaults.
6. Click the OK button to save Customer Prefs.
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Custom Forms: Page Setup Alert
Big Business alerts you when you are attempting to print a Custom Form and the
selected printer does not match the Page Setup saved with the Custom Form. Click Yes
on the alert, to change the Page Setup for the current print job.

To Set the Page Setup for a Custom Form (permanently):

1.  Go to the InfoCenter toolbar, and select the Custom Form tool
2.  Select your Custom Form, and click the OK button.
3.  Select Page Setup from the File menu (within the Custom Form window)
4.  Make necessary changes and click OK.
Changing the Page Setup changes the margins.  If objects on your form are outside the new
margins, an alert will offer to Automatically Adjust Objects on your form.  Click Adjust to
accept the adjustment.
5.  Select Save from the File menu to save changes.

It is a good habit to always use Save As... when you have changed your Custom Form.
If there are any unexpected results with the newly saved form, you can revert to the
original.
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Custom Forms: Editing Existing
Editing an Existing Custom Report
After you have created a custom report, you can make revisions to it if necessary.

To edit an existing custom report:
1. Click the Custom Form/Report tool in the Info Center toolbar.
2. In the Custom Forms/Reports window, select the form or report you want to edit,
then click the OK button.
3. Make any necessary changes, then choose Save from the File menu inside the Custom
Forms/Reports window.
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Custom Forms: Importing
Big Business includes an Import button on the Report/ Form Name window in the
Custom Form tool.

To Import Report/Form Templates:
1.  Open the Custom Form/ Report tool.
2.  Click the Import button.
3.  Select the file to import.
The imported Report/ Form opens directly into the Custom Form/ Report editor and has
not yet been saved.
4.  Make any changes you want including setting the Page Setup (from the small file
menu within the window).
5.  Choose Save As... from the small File menu and give your new Form or Report a
name.  Close the Custom Form/ Report editor window.
6.  Test your new form or report from its place of use (i.e. if it's an Invoice Form, open
an existing Invoice to print a test page).

If you have found an older Custom Form Template for Import (in the Solutions
Database, on an older CD, or exported from an older version of Big Business) follow its
accompanying instructions (or email the template to support@bigbusiness.com for
conversion).
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Custom Forms: Exporting
Big Business includes an Export button on the Report/ Form Name window in the
Custom Form tool.  Use this button to export any existing Custom Form or Report, in
order to:

•  Archive it for future use
•  Move it to another data file
•  Send it to support@bigbusiness.com for review or to share with other users.

To Export Report/Form Templates:
1.  Open the Custom Form/ Report tool.
2.  Select the Report/ Form to be exported.
3.  Click the Export button.
4.  In the Save dialog which appears, choose a location to save the form and give it a
name.
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Custom Forms: Deleting
Big Business 3.0.6 adds a new Delete button on the Report/ Form Name window in the
Custom Form tool.  Use this button to delete any existing Custom Form or Report that is
no longer of use.  You may want to export a copy first, in case you change your mind in
the future.

To Delete Report/Form Templates:

1.  Open the Custom Form/ Report tool.

2.  Select the Report/ Form to be deleted

3.  Click the Delete button.

You will be asked to confirm your intent to PERMANENTLY delete the selected form.

4.  Click Delete to confirm.

5.  Select another Report/ Form to edit, or click the Cancel button to close the window.
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Custom Forms: Updating Templates
Big Business stores the Templates for the Custom Form/Report tool in your Data File
and automatically updates them as needed.

To Manually Update the Templates:

1.  Check the Templates folder in your Big Business folder for the Report Templates.  If
you have downloaded an update to Report Templates, replace the existing Report
Templates file with the new one.

2.  In Big Business, go to the InfoCenter toolbar.
3.  Hold down the Shift, Option, and Command keys on the Mac; or the Shift, Control,

and Alt keys in Windows; and click on the Custom Form Report tool.
The message, "Loading Templates," should display briefly.
4.  On the Report/Form List, click the New button.
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Custom Forms: Accessing Related Information
Big Business lets you access related information in some Custom Forms and Reports.

Customer transactions (Quote, Sales Order, and Invoice) include access to information
from the Customer Card such a Phone or Custom fields.

Vendor transactions (Purchase Order, and Bill) include access to information from the
the Vendor Card such a Phone or Custom fields.

Line Item transactions (Quote, Purchase Order, etc.) include access to information from
the Item Card such as Inventory or Custom fields.
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Custom Forms: Editing Tips

Here are a few tricks, which may help:

1. Select an object and use the arrow keys on your keyboard to move it

2. Hold the Ctrl Key (on Windows, or the Command key on Mac) and use the arrow
keys to resize an object.  Left is narrower; Right is wider.  Up is shorter; Down is
taller.

3. Drag over objects to select them.  For example if trying to select a one-pixel
wide line, draw a rectangle with your mouse.  Everything inside the rectangle is
selected.  Shift-click any extra objects selected, in order to deselect them.

4. When you are creating a New report, you select an appropriate template.  The
template provides several functions including identifying where your form should be
printable from (e.g. an Invoice), what the base table for the form or report is
(Invoices), and what fields are available for insertion on your form (Invoice fields).
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Custom Forms: Template for 1099s.
Big Business includes a Custom Form Template for printing Vendor 1099s.

To print 1099s:

1.  From the InfoCenter toolbar, select the Custom Form tool.

2.  Click the New button, and select the Vendor1099s template.
To load current templates, close and reopen the Custom Form tool while holding Shift-Ctrl-Alt
(Shift-Option-Command on a Mac).  You will see the Loading Templates dialogue.

3.  On the 1099 Template, go to the small File menu and select Page Setup.  Verify the
Page Setup, then click OK.

4.  From the small File menu, select Save As... and enter a name (e.g. "My1099s") and
Save.

5.  Open the Vendor QuickSearch and find the Vendors who need 1099s.  For example,
select the search, "Send 1099  Is...  Yes."

6.  Click Print.  On the Print Options list click once on your form ("My1099s") and click
OK.  Double-click to set multiple copies.
It is recommended that you print on plain paper first to determine the layout is correct.

7.  Enter the Date Range when prompted (e.g. 01/01/08 - 12/31/08).
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Custom Forms: Date, Time, or Page Number
To add the Date, Time, or Page Numbers to forms created with the Custom
Form/Report tool:

1.  Select the Field tool (rectangle with a diagonal)
2.  Draw a rectangle, where you want the field to appear
The Field Selection window appears
3.  Using the pulldown for Variable, select Date, Time or Page Number.
4. Use the Format pulldown to select formatting options
5. Check Page Setup from the (small) File menu and click OK.
If prompted to Adjust items, Allow the adjustments.

Tips:
Always use “Save As...” to save a modified form.  You may have damaged the form in
your recent changes, and it’s much easier to go back an edit a previous version than to
figure out what went wrong in your recent changes.

Always test Custom Forms from their place of use in the application.  Printing from the
Custom Form/Report tool may yield different results including printing 20 records!
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Custom Forms: Formatting Numbers
By default, dollar amounts on the Custom Form templates in Big Business are formatted
to accommodate values upto $999,999.99.  If an entry or calculated result exceeds this
amount it will be displayed or printed as, "<<<<<<<<<".

To Change the Display of Numbers:

1.  Double-Click on the Field or Variable

2.  Insert the cursor into the Format field.

3.  Make the appropriate changes.

4.  Resize the field or variable to accommodate longer entries.  This is most easily done
by selecting the field and holding the Command (Apple or Ctrl) key while hitting the
right arrow key on you keyboard to stretch the field.

5.  Save your custom form/report.

For example, the default Format is, "###,###.00" which displays optional places (#) upto
the hundred-thousand column and always displays pennies (.00).  Changing this to
"##,###,###.00" will allow the field to display results upto $99,999,999.99.
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Custom Forms: Printing Inverted
Big Business 2.5 includes an update to the Custom Form/Report tool which is more
sensitive to not have the Page Setup correctly specified.

Before saving your Custom Form:

1.  From the File menu (within the Custom Form tool) select Page Setup.

2.  Confirm that the correct Printer and Paper Size are selected, and click OK.

3.  If asked, Allow Adjustments (to fit your form onto the "new" page setup).

4.  Save changes to your form.  It is recommended that you use the Save As... option, to
avoid writing over a working form with an untested form.
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Custom Forms: Misaligned
If you have printing alignment problems in Custom Forms created in a prior version of
Big Business, try the changes below to re-align the form.

Try each of the following changes (one at a time) to correct alignments:

Change the Paper selection in the Page Setup:
1.  Open the Custom Form tool and select your form.
2.  Select Page Setup from the small File menu.
3.  Choose paper size--use Letter, not Letter(Small)--and click OK.
4.  If prompted to Automatically Adjust objects, choose Adjust.
5.  Save As... [test#1]
6.  Test printing (i.e.from Invoice not Custom Form tool).

Change the Use Physical Page/ Use Printable Area Option:
1.  Open the Custom Form tool and select your form.
2.  From the small Options menu, select Use Printable Area, or Use Physical Page,
whichever is not currently selected.
3.  If prompted to Automatically Adjust objects, choose Adjust.
4.  Save As... [test#2]
5.  Test printing (i.e.from Invoice not Custom Form tool).

Move everything on the form:
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Custom Form and Report Service
Big Business Support now offers Custom Forms and Reports as a service at a flat fee:

This item covers one complete Custom Form or Report for use with Big Business 3.0 or
higher.   Included are help with specification, draft though final versions of the report,
three minor revisions, and  installation instructions, all provided via email.  Testing
and validation of report results are the recipient's responsibility.  Within the limits of
BB database architecture and data availability, all manner of reports are possible
including all manner of predefined searching, sorting, and calculation to provide the
answers you need to keep your business at your fingertips.
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